OpenGL Out of Date

Description: Report bugs and ask questions regarding PGE here.
Forum rules: Here you can ask any question related to PGE Project components:


Any questions related to LunaLUA project please ask HERE (LunaLUA subsection)
Any questions related to SMBX-38A (1.4.x) Chinese project please ask HERE (SMBX-38A subsection)
Moderators: Semi-moderatos, Moderators

Harley01715 M
Topic author, Passerby
Passerby
Harley01715 M
Topic author, Passerby
Passerby
Reputation: 0
Posts: 1
Joined: 30 Dec 2016
Twitter

Post #1by Harley01715 » 30 Dec 2016, 2:49

I've tried to play a level I made but it failed because of OpenGL out of date
Harley :windows:

Wohlstand M
Lead Developer
Lead Developer
Avatar
Wohlstand M
Lead Developer
Lead Developer
Age: 27
Reputation: 387
Posts: 1427
Joined: 15 Feb 2014
Location: Moscow, Russia
Website Skype YouTube

Post #2by Wohlstand » 30 Dec 2016, 9:21

PGE Engine supports three rendering interfaces: OpenGL 3, OpenGL 2 and Software renderer. Use command-line arguments "--render-sw", "--render-gl3", "render-gl2" to choose one of them. By default, it is detecting automatically. Software renderer must work always.
Have you installed your video drivers? Without video drivers will work the software implementation of OpenGL or it will not work.


Return to “Troubleshooting”