I crashed it.

Description: It's archive, posting new is here viewforum.php?f=11

Something Fawful
Topic author, Citizen
Citizen
Avatar
Something Fawful
Topic author, Citizen
Citizen
Reputation: 0
Posts: 9
Joined: 28 Jan 2015

Post #1by Something Fawful » 8 Apr 2015, 1:15

It told me to post this, so here!

We're sorry, but PGE Editor has crashed.
Reason: Signal Segmentation Violation [SIGSERV]


/media/brian/Not SSD/brian/Documents/PGE_Project/pge_editor() [0x443d86]
/media/brian/Not SSD/brian/Documents/PGE_Project/pge_editor() [0x445f82]
/lib/x86_64-linux-gnu/libc.so.6(+0x36eb0) [0x7fba7ed21eb0]
/media/brian/Not SSD/brian/Documents/PGE_Project/pge_editor() [0x716826]
/media/brian/Not SSD/brian/Documents/PGE_Project/pge_editor() [0x79650b]
/media/brian/Not SSD/brian/Documents/PGE_Project/pge_editor() [0x796823]
/media/brian/Not SSD/brian/Documents/PGE_Project/pge_editor() [0x1393001]
/media/brian/Not SSD/brian/Documents/PGE_Project/pge_editor() [0x9c9243]
/media/brian/Not SSD/brian/Documents/PGE_Project/pge_editor() [0x1392ec2]
/media/brian/Not SSD/brian/Documents/PGE_Project/pge_editor() [0x1333187]

I was working on classic events, I think I was clicking on one after adding some new layer related stuff. /media/brian/Not SSD is my Internal hard drive, but not the SSD one my OS is installed on.

If you need the level I was working on let me know.

Edit: Oh hey I caused it again, far as I can tell it's the exact same error message so not going to bother with it. Again I was clicking on one of my events.

Wohlstand M
Lead Developer
Lead Developer
Avatar
Wohlstand M
Lead Developer
Lead Developer
Age: 25
Reputation: 334
Posts: 1320
Joined: 15 Feb 2014
Location: Moscow, Russia
Website Skype YouTube

Post #2by Wohlstand » 8 Apr 2015, 15:41

First of all: what version you use now?

Something Fawful
Topic author, Citizen
Citizen
Avatar
Something Fawful
Topic author, Citizen
Citizen
Reputation: 0
Posts: 9
Joined: 28 Jan 2015

Post #3by Something Fawful » 9 Apr 2015, 2:18

Right... that sort of information tends to be helpful to have...

Editor, version 0.3.0.0-beta
Build date: Mar 16 2015 02:08:53

Downloaded from the home page. OS is [still] Linux (Kubuntu)

Wohlstand M
Lead Developer
Lead Developer
Avatar
Wohlstand M
Lead Developer
Lead Developer
Age: 25
Reputation: 334
Posts: 1320
Joined: 15 Feb 2014
Location: Moscow, Russia
Website Skype YouTube

Post #4by Wohlstand » 9 Apr 2015, 2:53

Something Fawful wrote:Right... that sort of information tends to be helpful to have...

Editor, version 0.3.0.0-beta
Build date: Mar 16 2015 02:08:53

Downloaded from the home page. OS is [still] Linux (Kubuntu)
Oh, Kubuntu, I tried it under VirtualBox and had some unstable things with it. But by anyway I will try to check something under them and will debug editor under it.
I'm currently under Linux Mint with MATE (Installed with Cinnamon, but it crashes, crashes, freezing, crashes.... :wacko: , therefore I changes it to MATE which more stable on my PC, but caja liking to freeze sometimes, but not so crytical like cinnamon was frozen: I should press Ctrl+Alt+F1, login under me and kill frozen cinnamon from ternimal or restart mdm service under root, then cinnamon works again, but all opened windows, programs, firefox, thunderbird, Qt Creator, Pidgin, etc. are losing :bads: because session was killed. With freezing & killing of caja I losing opened folders only but all other programs are still works perfectly).

Also I need to look for "how to correctly associate files with apps & set icons with KDE case", but with gnome works fine ( file association code piece here )


Return to “Troubleshooting”

Who is online (over the past 5 minutes)

Users browsing this forum: 1 guest