Is there any way to prevent Mouser from jumping?

Description: Subforum dedicated to SMBX-38A - a fan-made remake of the original SMBX Engine, made by 5438A38A.
Forum rules: This is official Europan/American community for the SMBX-38A. Suggested to don't post stuff for this engine outside this subforum.
Moderators: Yoshi021, Lx Xzit, 5438A38A, Semi-moderatos, Moderators

Coolio__ M
Topic author, Marquis
Marquis
Avatar
Coolio__ M
Topic author, Marquis
Marquis
Reputation: 25
Posts: 191
Joined: 15 May 2016
Location: The Metaverse

Post #1by Coolio__ » 19 Feb 2017, 19:05

As the title insists, I need to make it so that Mouser will still throw bombs but will not jump (setting him to Don't Move doesn't work).
~Previously known as DaveDaCat101~
Image
Image
Image (my project)
I Support
Image
Image
Image

Lx Xzit M
Moderator
Moderator
Avatar
Lx Xzit M
Moderator
Moderator
Reputation: 254
Posts: 578
Joined: 9 Nov 2015
Website

Post #2by Lx Xzit » 19 Feb 2017, 22:53

There's not an accurately way to disable it by completely (you would need to make a new AI for this, I mean, rewrite the mouser from scratch). But you can tell to the NPC that don't jump in every frame (however you'll see the Mouser makes a really little jump but it's for 1 frame only, almost not noticeable). You can try this:

Make a new Script and add this code:

Code: Select all

with npc(sysval(param1))
if .ysp < 0 then
.ysp = 0
end if
end with


Then, right click the mouser > scripts > (this script ^) and mark "Parallel execution", this is very important.
VISIT MY YOUTUBE CHANNEL! LX XZIT
Join our 38A Discord server!

Image


Return to “Super Mario Bros. X by 38A (SMBX-38A)”

Who is online (over the past 5 minutes)

Users browsing this forum: EclipseMain, GreenLight And 1 guest