Levels Not Showing In Folder

Description: Report bugs and ask questions regarding PGE here.
Forum rules: Here you can ask any question related to PGE Project components:


Any questions related to LunaLUA project please ask HERE (LunaLUA subsection)
Any questions related to SMBX-38A (1.4.x) Chinese project please ask HERE (SMBX-38A subsection)
Moderators: Moderators, Semi-moderatos

K-leb
Topic author, Nice citizen
Nice citizen
Avatar
K-leb
Topic author, Nice citizen
Nice citizen
Reputation: 0
Posts: 14
Joined: 18 Oct 2015

Post #1by K-leb » 4 Apr 2016, 15:48

When I save or open levels using the PGE Editor, I can see them in their respective world's directory. However, if I go to their respective directory through other means, namely just using Windows Explorer, I can't see the levels nor their custom folders.

Is this normal?
One day I'll release a SMBX episode...

Wohlstand M
Lead Developer
Lead Developer
Avatar
Wohlstand M
Lead Developer
Lead Developer
Age: 26
Reputation: 372
Posts: 1340
Joined: 15 Feb 2014
Location: Moscow, Russia
Website Skype YouTube

Post #2by Wohlstand » 4 Apr 2016, 16:28

Try the "file" -> "Open folder of current file", and you will see that folder where your actual file has been saved, I bet you just missed up with a folder :blum:

K-leb
Topic author, Nice citizen
Nice citizen
Avatar
K-leb
Topic author, Nice citizen
Nice citizen
Reputation: 0
Posts: 14
Joined: 18 Oct 2015

Post #3by K-leb » 6 Apr 2016, 10:32

I tried what you did, Wohlstand, and it shows the folder, but I still can't see the levels. I can see the custom folders, but that's because I decided to manually create them in Windows Explorer and, through opening for a file in the PGE editor, deleted the custom folders created by the editor.
Last edited by K-leb on 6 Apr 2016, 11:17, edited 2 times in total.
One day I'll release a SMBX episode...

Wohlstand M
Lead Developer
Lead Developer
Avatar
Wohlstand M
Lead Developer
Lead Developer
Age: 26
Reputation: 372
Posts: 1340
Joined: 15 Feb 2014
Location: Moscow, Russia
Website Skype YouTube

Post #4by Wohlstand » 6 Apr 2016, 11:12

K-leb wrote:I tried what you did, Wohlstand, and it shows the folder, but I still can't see the levels. I can see the custom folders, but that's because I decided to manually create them in Windows Explorer and, through opening for a file in the PGE editor, deleted the custom folders created by the editor.
If editor can see that files in that folder, those files are exists. Are you have tonn other files on that folder? Just look carefully, also show the hidden files. Also, if you installed PGE via installer, those level files are "known", therefore their extensions are may be hidden if you still have checked hiding of the file extensions. Those files are must be marked with mushroom icon (for SMBX64/38A level files) or Gyro cat for LVLX files. World map files are has globe icon and mushroom for SMBX64/38A and Gyro for WLDX.

Just my screenshot of random episode folder :blum:
Spoiler
Image

K-leb
Topic author, Nice citizen
Nice citizen
Avatar
K-leb
Topic author, Nice citizen
Nice citizen
Reputation: 0
Posts: 14
Joined: 18 Oct 2015

Post #5by K-leb » 6 Apr 2016, 11:17

I already have those settings on.

I have another problem, which is more major.
I also can't even access my world from the game. I downloaded SMBX 3.0.02 and deleted every world, then created a folder for my project. It has level files and a world file in it and everything, but the game shows absolutely nothing after I select 1 player or 2 player.
One day I'll release a SMBX episode...

Wohlstand M
Lead Developer
Lead Developer
Avatar
Wohlstand M
Lead Developer
Lead Developer
Age: 26
Reputation: 372
Posts: 1340
Joined: 15 Feb 2014
Location: Moscow, Russia
Website Skype YouTube

Post #6by Wohlstand » 6 Apr 2016, 11:22

Oh, you forgot to set an episode title, because SMBX is dumb and shows empty string as episode name (PGE Engine just showing a world filename if episode title is not set)
http://pgehelp.wohlsoft.ru/worldediting/worldedit_properties.html
Also, PGE Editor always asks you to set a leve/world title if you doing Save-As
I think, I will add warning message about missed episode title (but I will don't block saving), where saving into SMBX 1.3 format, and that is possible empty title in the game menu

K-leb
Topic author, Nice citizen
Nice citizen
Avatar
K-leb
Topic author, Nice citizen
Nice citizen
Reputation: 0
Posts: 14
Joined: 18 Oct 2015

Post #7by K-leb » 6 Apr 2016, 13:27

No, my world definitely has an episode title.

This is getting bizarre.
One day I'll release a SMBX episode...

Wohlstand M
Lead Developer
Lead Developer
Avatar
Wohlstand M
Lead Developer
Lead Developer
Age: 26
Reputation: 372
Posts: 1340
Joined: 15 Feb 2014
Location: Moscow, Russia
Website Skype YouTube

Post #8by Wohlstand » 6 Apr 2016, 13:41

Mayby you have another world map files in same folder, or just file is invalid. Try to take fresh laboratory build, resave file and then retry. Are you have LunaLUA build of SMBX? If yes, also try to take night build of LunaLUA and apply it over your build.


Return to “Troubleshooting”

Who is online (over the past 5 minutes)

Users browsing this forum: 1 guest