[Resolved] PGE Editor crashes after the splash screen loads?

Description: Report bugs and ask questions regarding PGE here.
Forum rules: Here you can ask any question related to PGE Project components:


Any questions related to LunaLUA project please ask HERE (LunaLUA subsection)
Any questions related to SMBX-38A (1.4.x) Chinese project please ask HERE (SMBX-38A subsection)
Moderators: Semi-moderatos, Moderators

Hy-Longcat
Topic author, Passerby
Passerby
Hy-Longcat
Topic author, Passerby
Passerby
Reputation: 0
Posts: 2
Joined: 7 Apr 2019

Post #1by Hy-Longcat » 7 Apr 2019, 17:32

Hello, all! This is my first post here.
I've been using SMBX for at least a year now (I've been interested in it for way longer though) on my 2009 MacBook (it's running MacOS High Sierra), but it seems that despite having worked at least half a month ago, PGE Editor isn't working. I've checked my logs, and this is what I got:

[i]Warning: Wrong splash image: /private/var/folders/kk/m7m7y5ts75v91x61h0r20j3r0000gr/T/AppTranslocation/A2C1F5DE-5428-4D90-AB15-72A1D2CB38F1/d/configs/SMBX-2.0-Integration/data/commonGFX/editor_splash.png, using internal default
Critical: Level graphics path not exists: /private/var/folders/kk/m7m7y5ts75v91x61h0r20j3r0000gr/T/AppTranslocation/A2C1F5DE-5428-4D90-AB15-72A1D2CB38F1/graphics/
Fatal: <Error, application closed>[/i]



Any way to address this?

Thanks in advance!

Wohlstand M
Lead Developer
Lead Developer
Avatar
Wohlstand M
Lead Developer
Lead Developer
Age: 27
Reputation: 387
Posts: 1424
Joined: 15 Feb 2014
Location: Moscow, Russia
Website Skype YouTube

Post #2by Wohlstand » 8 Apr 2019, 10:59

Where you have placed "PGE Project" folder? It must be moved into your "~/Applications" folder to work correctly. The thing that happen you see, it's because of damned sandbox.

When you using SMBX2 Integration pack with non-Windows or separated Windows-specific PGE installation, please, put into the "main.ini" the absolute `application-path` to your actual SMBX2's `data` folder. Because of sandbox damn, you can't just put PGE apps into SMBX2's `PGE` folder. That possible on Linux, but not on the Mac.

Hy-Longcat
Topic author, Passerby
Passerby
Hy-Longcat
Topic author, Passerby
Passerby
Reputation: 0
Posts: 2
Joined: 7 Apr 2019

Post #3by Hy-Longcat » 19 Aug 2019, 3:44

Many thanks!


Return to “Troubleshooting”

Who is online (over the past 5 minutes)

Users browsing this forum: Animebryan And 10 guests