PGE editor not launching, even with minimum reqirements

Description: Report bugs and ask questions regarding PGE here.
Forum rules: Here you can ask any question related to Moondust Project (former PGE Project) components:


Any questions related to SMBX2 project and LunaLua library please ask HERE (SMBX2 subsection)
Any questions related to SMBX-38A (1.4.x) Chinese project please ask HERE (SMBX-38A subsection)
Any questions related to TheXTech Project please ask HERE (Vanilla SMBX and The X-Tech subsection)
Moderators: Semi-moderatos, Moderators

The1_1cliche0310
Topic author, Passerby
Passerby
The1_1cliche0310
Topic author, Passerby
Passerby
Reputation: 0
Posts: 1
Joined: 11 May 2021

Post #1by The1_1cliche0310 » 11 May 2021, 14:14

Hello there.
I'm having a problem with all other PGE applications apart from the engine where whenever I launch it, it would instantly close and show me an error message that says "PGE Editor cannot be opened because of a problem".
My mac's version is 10.12 (Sierra) and my graphics are Intel HD Graphics 6000 1536 MB. I also use the lab version as the stable version didn't work.
May you please work on a fix for this, or at least suggest a fix for this problem?
I can provide error details if asked.

Wohlstand M
Lead Developer
Lead Developer
Avatar
Wohlstand M
Lead Developer
Lead Developer
Age: 29
Reputation: 512
Posts: 1612
Joined: 15 Feb 2014
Location: Moscow, Russia
Website Youtube channel URL Skype Tencent QQ

Post #2by Wohlstand » 11 May 2021, 15:16

Hm... Last time I had to make sure all apps should work on at least El Capitan, however, that depends on the Qt toolchain which makes the limit... I see, the minimal supported version by Qt 5.14 toolchain (that got used to building the thing) requires the macOS 10.13 High Sierra minimum. There are two ways on how to get it to work for you:
- Update your macOS version
- I will need to produce the second build variant using an older Qt toolchain for old macs target especially

Anyway, soon I do plan to update the Qt toolchain to make the universal build of all things that will work on both x86_64 and arm64 with no Rosetta usage. At least, Qt 5.15 does also require macOS 10.13 minimum. However, Qt 6 requires macOS 10.14.


Return to “Troubleshooting”

Who is online (over the past 5 minutes)

Users browsing this forum: 1 guest