What does this mean?

Description: Report bugs and ask questions regarding PGE here.
Forum rules: Here you can ask any question related to PGE Project components:


Any questions related to LunaLUA project please ask HERE (LunaLUA subsection)
Any questions related to SMBX-38A (1.4.x) Chinese project please ask HERE (SMBX-38A subsection)
Moderators: Semi-moderatos, Moderators

TheGameyFireBro105
Topic author, Passerby
Passerby
TheGameyFireBro105
Topic author, Passerby
Passerby
Reputation: 0
Posts: 2
Joined: 27 Feb 2021

Post #1by TheGameyFireBro105 » 18 Mar 2021, 23:49

This keeps happening. What is the issue? :SOS:
Spoiler
We're sorry, but PGE Editor has crashed.
Reason: Signal Segmentation Violation [SIGSEGV]


================================================
Additional information:
================================================
Platformer Game Engine - Editor version: 0.3.2-dev
Architecture: x86 (32-bit)
GIT Revision code: 164c032
GIT branch: master
Build date: Jul 19 2020 21:49:23
================================================
Qt 5.6.3
SDL2 2.0.13
SDL Mixer X 2.5.0
================================================
Please send this log file to the developers by one of ways:
- Via contact form: https://wohlsoft.ru/contacts/
- Official forums: https://wohlsoft.ru/forum/
- Make issue at GitHub repo: https://github.com/WohlSoft/PGE-Project

================================================

Wohlstand M
Lead Developer
Lead Developer
Avatar
Wohlstand M
Lead Developer
Lead Developer
Age: 28
Reputation: 509
Posts: 1602
Joined: 15 Feb 2014
Location: Moscow, Russia
Website Youtube channel URL Skype Tencent QQ

Post #2by Wohlstand » 19 Mar 2021, 0:59

Hi there, you do use the old version. Please upgrade it. If the crash repeats again, please tell me what you actually doing to cause this crash? Or which files you trying to open? Please PM me those files (if you want to keep them in a secret) and their custom data if the crash is still reproducible after the update.

SIGSEGV means there is a wrong in-memory operation usually caused by the wrong array index requesting or accessing into the invalid pointer, etc.

If you do use the standalone kit, simply download the update from the laboratory. If you do use the SMBX2, you should run the "data/PGE/update_pge.cmd" script that will automatically download the update for you.

Added after 1 hour 6 minutes:
P.S. I'll move this into general PGE/Moondust troubleshooting topic as this is the case of Editor itself, totally not related to SMBX2.

TheGameyFireBro105
Topic author, Passerby
Passerby
TheGameyFireBro105
Topic author, Passerby
Passerby
Reputation: 0
Posts: 2
Joined: 27 Feb 2021

Post #3by TheGameyFireBro105 » 22 Mar 2021, 21:42

Thanks!!!! :mrgreen:


Return to “Troubleshooting”

Who is online (over the past 5 minutes)

Users browsing this forum: 1 guest