[RESOLVED] PGE crashes on start.

Description: It's archive, posting new is here viewforum.php?f=11

User199x
Topic author, Passerby
Passerby
User199x
Topic author, Passerby
Passerby
Reputation: 0
Posts: 2
Joined: 28 Apr 2018

Post #1by User199x » 28 Apr 2018, 7:57

Hi, I'm new here.

You see, when I went back to level creation in PGE, it loads correctly. But when the level data loading screen reaches "3/6 Loading Blocks...", all of a sudden PGE
crashes. This is what it reads:

Spoiler
Lo lamentamos, pero el editor ha colapsado.
Razón: Floating-point exception [SIGFPE]



UnhandledExceptionFilter
RtlCaptureStackContext
RtlGetAppContainerNamedObjectPath
Yes, I'm mexican by the way. But what matters is that PGE simply crashes. Any help is appreciated.

Wohlstand M
Lead Developer
Lead Developer
Avatar
Wohlstand M
Lead Developer
Lead Developer
Age: 26
Reputation: 372
Posts: 1338
Joined: 15 Feb 2014
Location: Moscow, Russia
Website Skype YouTube

Post #2by Wohlstand » 28 Apr 2018, 12:43

Seems you have outdated PGE toolchain, amigo, and you would to update it. I have updated stack tracing and this one is very outdated.
Do you using standalone PGE toolchain or in-SMBX2? To upgrade standalone, use online installer (re-download it please), and if you are using in-SMBX2 PGE Toolchain, to update it, follow this manual: viewtopic.php?f=11&t=1977

After you will update PGE toolchain, please tell me, is crash still happen or it was gone?

User199x
Topic author, Passerby
Passerby
User199x
Topic author, Passerby
Passerby
Reputation: 0
Posts: 2
Joined: 28 Apr 2018

Post #3by User199x » 28 Apr 2018, 20:56

Thanks for responding. I'll come back later after updating.

Wohlstand M
Lead Developer
Lead Developer
Avatar
Wohlstand M
Lead Developer
Lead Developer
Age: 26
Reputation: 372
Posts: 1338
Joined: 15 Feb 2014
Location: Moscow, Russia
Website Skype YouTube

Post #4by Wohlstand » 30 Apr 2018, 2:09

As User199x reported me that everything works fine now, I closing this.


Return to “Troubleshooting”