[Solved] [Windows XP incompatibility because of Qt 5.8] PGE Crash!!!!!!!!

Description: Report bugs and ask questions regarding PGE here.
Forum rules: Here you can ask any question related to PGE Project components:

Any questions related to LunaLUA project please ask HERE (LunaLUA subsection)
Any questions related to SMBX-38A (1.4.x) Chinese project please ask HERE (SMBX-38A subsection)
Moderator: Moderators

Love Bodhi
Topic author, Duke
Love Bodhi
Topic author, Duke
Age: 19
Reputation: 13
Posts: 101
Joined: 14 Nov 2014
Location: China

Post #1by Love Bodhi » 20 Mar 2017, 14:34

When I open PGE, it just crushes with a follow fatal error dialog
Crash2.PNG (6.63 KiB) Viewed 308 times

Same occur when I downloaded in the Laboratory when I run other than pge_engine.exe
(Sorry for my bad English.I'm Chinese)

Join my Discord: https://discord.gg/22GUfFq


Wohlstand M
Lead Developer
Lead Developer
Wohlstand M
Lead Developer
Lead Developer
Age: 25
Reputation: 328
Posts: 1308
Joined: 15 Feb 2014
Location: Moscow, Russia
Website Skype YouTube

Post #2by Wohlstand » 20 Mar 2017, 15:11

It's not a crash, it's Qt since 5.8 no more supports for Windows XP, and referred missing function is exists in kernel32.dll since Windows Vista.

So, I think, you can re-download laboratory build for now and retry:
  • PGE Engine (no more uses Qt, but not tested on Windows XP after reworks)
  • GIFs2PNG (tested and works)
  • LazyFixTool (tested and works)
  • PNG2GIFs (tested and works)

The solution is usage of Qt 5.7 to build Editor, MusPlayer, Maintainer and Calibrator to take them work on Windows XP
(I think, I'll setup AppVeyor to do two builds: on latest Qt version and on Qt 5.7 to provide Windows XP compatible builds)
But okay, for now I'll turn back Qt 5.7 for Windows because of this case, so, next laboratory update will take back support of Windows XP

EDIT: I has been toggled build machine to build with Qt 5.7 to repair support for Windows XP:
https://github.com/WohlSoft/PGE-Project/commit/8f ... 61a9bc452b9b36965721c7ae77c0cb
After approximately half of hour the new laboratory built will be uploaded, then you will be able to re-download it ;-)

EDIT2: Everything has been built! Feel free to try out!

Return to “Troubleshooting”

Who is online (over the past 5 minutes)

Users browsing this forum: 1 guest